题目描述
输入一行单词序列,相邻单词之间由1个或多个空格间隔,请对应地计算各个单词的长度。 注意,如果有标点符号(如连字符,逗号),标点符号算作与之相连的词的一部分。没有被空格间开的符号串,都算作单词。
输入描述
一行单词序列,最少 1 个单词,最多 300 个单词,单词之间用至少 1 个空格间隔。单词序列总长度 不超过 1000。
输出描述
依次输出对应单词的长度,之间以空格间隔。
样例输入
She was born in 1990-01-02 and from Beijing city.
样例输出
3 3 4 2 10 3 4 7 5
题解
cpp
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cctype>
#include <algorithm>
using namespace std;
int main()
{
string s;
cin >> s;
cout << s.size();
while (cin >> s)
{
cout << " " << s.size();
}
return 0;
}
本文最后更新于2022年4月9日,已超过 2 年没有更新,如果文章内容或图片资源失效,请留言反馈,我们会及时处理,谢谢!